Pages: 1 ... 11 12 13 14 16 18 19 20 21 ... 141

06/20/11

  10:17:34 pm, by The Dreamer   , 610 words  
Categories: Hardware, Storage

TARDIS got a new drive...sort of

So, after I finally replaced the backup drive on gumby...I noticed a strange whining sound, but I couldn't figure out where it was coming from, so I went on to other projects.

Later when I was going to bed, I found it really annoying...so I went to look for the source.

Well, it was emanating from TARDIS....I eventually decided it was probably the external drive, and tried to safe remove and power it off to confirm. I couldn't get it to disconnect, and TARDIS was wanting to reboot after having applied patches but also wanting to know if I wanted to update other stuff.

So, I ended up turning the external drive off hard. That stopped the whine. Eventually, I got things mostly patched and set it reboot and went off to bed.

Full story »

  07:01:02 am, by The Dreamer   , 134 words  
Categories: ReplayTV

Just heard the news, ReplayTV is dead.

Important Announcement!

The ReplayTV Electronic Programming Guide (EPG) Service will be permanently discontinued on July 31, 2011. After this date, owners of ReplayTV DVR units will still be able to manually record analog TV programs, but will not have the benefit of access to the interactive program guide. Effective immediately, monthly billing for the ReplayTV service to remaining customers has been suspended.

The industry conversion to HDTV is complete and ReplayTV DVRs are unable to take advantage of the wealth of HDTV programming. Please contact your service provider for current offerings.

Guess my (2) lifetime(s) is about to end.... :..(

Wonder if its just guide data, or if the other services like time setting, activation, IVS are shutting down as well.

Guess I don't need to be looking to replace the drive in one of my lifetime units.

Tags: dnna, replaytv

06/18/11

  05:40:36 pm, by The Dreamer   , 841 words  
Categories: Hardware, Software, Storage

Gumby got a new drive

It isn't that new....in fact I had picked it up from a clearance table a couple months ago. But, it sure is tiny compared to what was sitting in its place before.

For sometime, the latest storage configuration was a pair 300GB firewire drives and a 1TB firewire drive connected to the box and its 160GB system drive. The 1TB drive broken into two partitions...1/3 & 2/3...the larger as MMCVideo storage and the smaller for local stuff. The 1TB replaced what was 3 300GB firewire drives, when one of the drives failed....and it was a total loss, but I had restored some 400GB from backuppc to recover.

I had kept the 2 remaining 300GB drives as a two set disk2disk backup of the system drive (with the help of Retrospect 6).

Well, the remaining two 300GB drives had started failing a few months back. One of them failed completely a couple months ago....prompting me to eventually buy a new drive.... But, the other 300GB drive continued to work more or less and I changed the backup schedule to only use that drive. It did lead to some bad crashes now and then, but apparently not enough to take it off.

This morning while I was looking at other things, including tweaking backuppc...and push some fulls now that I'm in a quiet period of system activity (gumby is now more of a TiVo Desktop machine than MMC, but its kind of a quiet period for new TV...even though I'm really behind on my watching, and could find that some recording didn't happen and then need to find somewhere to buy the show....)

But, I decided it was time to retire the other 300GB drive before something worse happened...and break out the 250GB drive I had purchased.

Full story »

06/05/11

  09:52:32 pm, by The Dreamer   , 1090 words  
Categories: General, Software, Networking, Android

I took The EFF Tor Challenge

Link: http://www.eff.org/torchallenge

Earlier in the week, I got an email from EFF about their Tor Challenge. I had looked at Tor some time ago, but it seemed like a hassle to use. But, I am a support of EFF, and not just because I had lots of ReplayTVs and now a few TiVos.

So, I decided to take another look at Tor....I had started worrying about my privacy with some of my online activities, and I do support various human rights issues, etc.

The challenge called for setting up a relay. So, I continued looking and what I needed to do to make it do that. ORPort prefers to be either 9001 or 443...well, wouldn't go on 9001 on Orac, it conflicted with another service that I'm already running. So, it would have to go on a different port.

That, meant figuring out how to NAT on my WRT54GS...it doesn't do port NAT on inbound forwards, so I had to figure out how to add entries to iptables to make that go. That took some doing, but eventually I got that working. Not before I accidentally lost my rc_firewall, and had to restore for a rather old version. I should probably see about doing some kind of automated backup...

It defaults to going with exit relay, and I decided to go ahead...but use the 'reduced exit relay' policy. To see how that would work.

I set bandwidth and transfer limits on things....but first instance on the 'Orac' actually hit the limit, which made it hard to night surf for my own reasons. And, while I was on the torproject site, I decided to take a look at Orbot for both my Android phone and my Android tablet. And, I suppose I'll want to run it on my laptop.

One problem I seemed to have is that I couldn't get tor to work locally on my android phone on wifi, but it worked on 3g. I figured its some kind of conflict with the tor network seeing the relay at the same IP. Though later it started working, maybe that was the relay went into hibernation. I did set up 'Orac' as a central proxy for everything at home. Strange that when I think of private surfing I tend to use my DSL and general surfing on Cox. I had gone with default gateway on 'Orac'...so it was going Cox.

With everything seeming to work well, I opted to set up another instance of 'box' to use my other Internet connection. That didn't go as well, because the ISP blocks a lot more inbound connections than the other. But, I got it working. And, I poked around some sites here and there before calling it a night.

Pages: 1· 2

  08:38:00 pm, by The Dreamer   , 601 words  
Categories: Hardware, Software, Computer, BOINC, Storage, Ubuntu

Got another brain for Orac

So, the other day, I was poking around on NewEgg.com, trying to decide if I wanted to get the upcoming ShellShocker. I spotted a single slot GT440 for a good price among the daily deals. While I was looking around, I saw other things that caught my interest...a powersupply tester. Or things that I needed to go with the card, like a DVI-I to VGA adapter. Also decided to grab a new fan, since it is probably only a matter of time that the fan in the other drive array on Orac to fail.

I ended up not getting the ShellShocker item.

I've been eyeballing getting a single slot 400 Series card for Orac for a while. Was originally going to get a 200 Series, and I did actually get one in a different ShellShocker deal. But, when I opened up Orac, I realized it wouldn't fit....due to its huge fan.

Not sure what I'll do with that card. But, I had been looking at 400 Series, because Zen came with a GT420....which I've learned is a pretty horrible, compared to the rest of the line. Especially when it comes to doing BOINC. I'll probably go GTS450 or GTX460....single slot, though I need to take a look inside someday to see if there's actually juice in there. Otherwise, maybe I'll want a second one of these...

So, I had picked up the card from the UPS Store on Friday...but I didn't get around to installing it today. I stopped checkarray before I shutdown. I changed the scheduling of checkarray to spread things out better.

Though I had a brief distraction this morning on another matter, which I'll be posting about soon...

But, I went and put it in...its a pretty tight fit sitting next to my PM eSATA card.

I wonder if I'll look into a slot fan to go in the open PCI slot there....the lower PCI slot is where 4 other eSATA....oh wait, I had gotten a PCI card that I was going to put into Orac. I wonder what happened to that project....

Pages: 1· 2

05/30/11

  09:48:00 am, by The Dreamer   , 892 words  
Categories: Hardware, Computer, BOINC, Roku XDS, Ubuntu, Other Linux

LHAVEN is dead, long live LHAVEN?

Well, I was getting really annoyed with it complaining and kicking out the replaced disk in LHAVEN. So, I shutdown the system and took out the disk, figuring it should just continue to run fine degraded until I get around to replacing it.

Well, it wouldn't power on after that. I went through everything, no joy. It had done this a while back when I tried adding something to it. It could just be the power supply has flaked out, but I don't have a tester or multimeter handy...so I can't really test it. Could buy a new PS...and I may do that.

But, I kind of suspected the drive issues weren't actually the drive but possibly some deeper hardware problem. So, I had been planning to replace LHAVEN at some point. It has done quite well, being circa 2002. Started out as a 64MB Duron 800MHz machine, eventually peaked at 2GB Athlon XP 3000+. It had replaced a Cyrix PR233 box that had gone up in smoke during a hot summer day in 2002, when the transformer outside blew....the computer survived the brownout and then blackout, but the fans didn't spin back up when power returned...so it burned itself up. Later I found one problem with this new system. It wouldn't resume after losing power. No BIOS setting to alter this behavior and I did try to see if there was alternate BIOS updates for it. It was kind of a painful machine to manage, because for some time kernels didn't have built-in support for all the SIS chipset stuff in it....so an update would roll out, and NIC was usually one of the things to definitely go missing. Which made for fun to rebuild a custom kernel upgrade for it. Eventually it got stable.

But, needing essentials like DNS, DHCP to be available after an extended outage...I moved these to another server (originally an old Pentium 75, which has evolved into what is known as 'box' today). For the longest time it was RedHat 7.2, and then RedHat 7.3 when fedora legacy switched to only supporting 7.3 and 9 releases. It continued after fedoralegacy stopped supporting it, I was building some of the packages for it by hand...like bind (in response to the Kaminsky exploit). There were parts of my network that wouldn't function without LHAVEN...like an old Windows 2000 box that was barely functioning...(old Gumby).

I nearly lost it during the Icepocalyse....but I tracked down motherboard replacement for it from geeks.com. It was a slighty newer mobo, but equivalent chipset. It did have some things the old mobo didn't, like USB 2.0 support (I didn't use USB and still don't), support for 2GB of RAM instead of 1GB...so I upped it for better BOINC'ng. And, faster CPUs....so I upped from 2200 to 3000.

At one time, I had turned it off to do some upgrades...which didn't pan out. Tried to slap a gigabit card into it...didn't work. Wouldn't get along with the on board stuff, and the BIOS didn't have ways to get things out of the way enough. It also never fixed the resume after power loss issue. But, during this process it failed to power on....but after a couple days, it came back and I decided to upgrade its UPS and hopefully it would make one last outage. Well, there were several others since then where it came back afterwards. But, looks like this is the last time for it.

Pages: 1· 2

  12:03:00 am, by The Dreamer   , 1362 words  
Categories: Software, Computer, Networking, WiFi, Ubuntu

Freeradius & DHCP Failover

Link: http://deployingradius.com/

So, ever since I looked at adding Mac Address Access Controls to my Airport Extreme...on top of WPA2 Personal, and the fact that my DHCP server only does reserved IPs, security. I used to do Mac Address Access Controls on my previous routers, but it was an easier interface to work with on those. And, I didn't realize how the Time Access worked on the Airport Extreme, the default allow all the time rule at the top tripped me up. So, I thought if I wanted it, I would need a RADIUS server...and I didn't know if I wanted to do that....yet.

But, after I woke one morning and couldn't seem to account for why there seemed to be so much data streaming through my Cox connection...there had been strange spikes in the past, but always figured it was something updating itself while I wasn't home (like iTunes and my podcast subscriptions). But, this one morning...there was no corresponding activity from any of my computers, and I didn't see anything obvious with my TiVos/ReplayTVs. Though I could've just missed it.

So, I fixed the Timed Access control and put my current devices in. With a note that I should really look into installing RADIUS somewhere, so that it would be easier to maintain the list than the airport utility. I would lose being able to find the MAC address of some new wireless device that doesn't have the MAC address stamped on it....for addition to my DHCP server.

Later during the setup in: Another Airport comes to Lunatic Haven I had wiped out the settings....and didn't feel like putting it back in again. Which made it more urgent (in my mind) to get RADIUS working.

So, I went online and searched and searched and searched...on how to do this. I had looked before, and wasn't all that successful. There's no simple how-to apparently. But, I found bits and pieces around, and decided to just go for it.

First, I installed freeradius on my Ubuntu server 'box'.

sudo apt-get install freeradius

It starts right away, now to make it work. And, debug it. Well, most of the examples were for older freeRADIUS versions, so things weren't where it said, or command line switches were different, or it didn't work. I did find some examples of MAC address authorization, but they involved 'Auth-Type := Local' in the /etc/freeradius/users file. But, the clients.conf part seemed right. I strongly considered just doing 'Auth-Type := Accept'...but I wanted to figure this mess out.

client 192.168.1.1 {
        secret = testing123
        shortname = airport
        nastype = other
}

So kept searching and searching....eventually, I found fragments on site called "Deploying RADIUS: Practices and Principles". It confirmed that I was basically on the right track, I just needed to figure out what to put in the users file to make it go from Auth-Reject to Auth-Accept.

Well, the example for MAC Address entry for users I had found was:

001122-334455  Auth-Type := Local,  User-Password == "testing123"

At first I was pointing my Airport Extreme at it and watching the debug output, and watching everything stop working now and then. But, eventually I used 'radtest' to test my freeRADIUS configuration. And, eventually, I found that what I needed was:

001122-334455  Cleartext-Password := "testing123"

And, all was good. I pointed my main Airport Extreme to it, and it everything adjusted and worked. I then pointed the new Airport Extreme at it and things continued to work.

Yay! :cool:

Pages: 1· 2

05/29/11

  10:48:00 pm, by The Dreamer   , 930 words  
Categories: Hardware, Computer, Networking, WiFi, Printers

Another Airport comes to Lunatic Haven

That's another Airport Extreme....

The corner where I put TARDIS and my HP Photosmart 8450xi printer have been having switch problems, or at least I that's what I thought. But, I have replaced the only cable to replace, and both switches. But, still the link will drop out of gigabit after a while. And, then it wouldn't go into gigabit at all anymore.

And, then PRTG reports that things over there disappear every night. What's strange is that its always around the same time.

I thought about buying some network testing equipment, and figuring out what it would take to run a new line in place of the existing one (should be easier than what it would take to run one to a new location). Or doing the ugly and stringing wire along the ceiling....

But, things started adding up....and I wondered just how much I needed the speed. Sure gigabit would help TARDIS backup faster, but that's about all over 100Mbps would get me. The printer is only 100Mbps, so no advantage there. And, likely would be the case for any network printer I were to put there. And, likely not much else is going in the corner any time soon that would need gigabit. So, I wondered about revisiting the WDS option using 802.11n now. I had survived for some time with 802.11g WDS both here and in the past.

Looking at WDS options with my Airport Extreme, it pretty much came down to two options....an Airport Express or an Airport Extreme. Express only has a 10/100BaseT port on it and its a big plug type thing, so if I wanted better than 100Mbps, it would have to be an Airport Extreme. I did look at other routers, but hard to tell if it would work or not, and I'd probably want something using OpenWRT or something and things started getting complicated again.

I do someday think I'll get an Airport Express...though it would require that I have Linux solution to manage it, some way to set it up in a turnkey solution....as a travel router.

But, while I was looking at other WiFi router options...I was looking on eBay, so I wondered about an Airport Extreme that way (instead of using my Educational discount on another).

And, I found some pretty reasonable prices for refurbished units, so I went for one.

Pages: 1· 2

  11:43:05 am, by The Dreamer   , 804 words  
Categories: Stuff, Software, Computer, VoIP, BOINC

Death to Skype! Bring me its head!

Link: http://jeff-duntemann.livejournal.com/281642.html

Years ago, I had installed Skype on various computers thinking that I'd jump into the whole using my computer for VoIP calling either as a supplement to doing VoIP using ATA's or successor. It revived buying webcams and/or headsets on my newer computers. I bought a webcam for my dad. But, he never used it.

And, I've never really used any of the many new webcams I keep buying either. But, recently I've met some friends on line that are into chatting online using Skype. I did do it once, and it was a strange experience actually talking to people....rather than the usual type into a window or web form chatting that I'm accustom to for online chat. But, they weren't into the webcam feature of Skype, so I don't know if I'll ever get to use that part for more than just as the microphone. (Which I might not do, since I bought a headset for one of my computers...)

Meanwhile, yesterday on Gumby....the computer I installed Skype and a(n HP) webcam onto, because ole TARDIS wasn't feeling up to getting new hardware (the plastic tab in some of its USB ports have broken off, though the kind of still work sometimes....not as bad as the old Gumby where the front USB ports didn't work at all anymore....And, I was using a PCCard USB adapter to help...)

Anyways, yesterday I recall seeing this EasyBits Games or something dialog come up, when I was checking some stuff on the machine. It had been up for over 16 (reached a max of 16.8 this time, TARDIS is currently at 35.52 days), but it seemed confused. A java app said it was out of memory, though there was plenty on the machine (over 1900MB free)...so I tweaked its JVM settings. Though later I discovered that PRTG had stopped running at some point. Someday I'll install Nagios, or something and replace that aspect of PRTG that I use. I had switched to running it, because bello-monitors-the.net ceased operation a few months back...and I was using it to monitor the performance and availability of this blog. At first PRTG seemed the solution to doing this...but its more annoying than just works, so I'll probably look at some other online service...

Anyways, suddenly with no explanation my screen went dark and the lights went out on Gumby...a moment later it was booting back up. Nothing in the event log to explain why it had gone down. I came back later to see the finished boot, and dismiss the various dialogs that come up during a boot and see why PRTG was complaining about something I was sure I had told it to stop monitoring (LHAVEN....I haven't finished that post yet). That's when I saw the huge gap in data, and it had apparently stopped working sometime yesterday morning (this unexplained reboot was around 5:27pm).

I vaguely recall seeing a strange dialog from Skype in reference to EasyBits Go games, seemed odd that Skype wanted me to install something like this. And, I have Skype in offline state on this computer...since I had upgraded to Zen...and Skype is online there. But, I dismissed it. I wasn't interested in it. But, later I saw that it had installed itself anyways. :##

Then a strange Flash Player install dialog, not the usual one from Adobe that comes up now and then. But, it seemed to do the normal Adobe Flash Player install...the except it was the kind that tried to install crapware with it, that you have to figure out the checkbox to uncheck to not get it before downloading it...while needing to check other boxes for it to proceed.

Guess I should've read it, because it was yet another part of the Crapware infestation that was coming to my computer via Skype/Microsoft.

Did a quick google search this morning, and found out how that its realy crapware, because the uninstall doesn't do anything...have to do more complicated stuff to remove it.

:rs::rs::rs::rs::rs:

Found the steps to eradicate it at: Jeff Duntemann's ContraPositive Diary - EasyBits GO, Skype, and The Crapware Problem

:rs::rs::rs::rs::rs:

Just firing off this quick blog post and then to reboot.... :cool:

Wonder if the Free AVG will catch it later, or if I should install something like Norton Internet Security (I seem to have gotten a 3-seat license, but I'm only using it on one computer at the moment....I do need to upgrade the version of Trend that is running on TARDIS, but getting NIS working and not working on Zen has been quite the hassle...so maybe I'm still looking, at least its SONAR isn't going after BOINC like NAV used to on TARDIS....wouldn't be so bad, if it didn't start doing that just after I extended it for another year.)

Wonder if I shouldn't just remove Skype while I'm at it.... :hmm:

  08:04:33 am, by The Dreamer   , 203 words  
Categories: VoIP, Cox HSI, AT&T DSL, Broadband

Saturday was a bad Cox day....

....another day that justifies also having DSL service.

Of course, on top of much more downstream and upstream, Cox also has lower latency. However, the thing that would benefit most...I have using DSL, my home telephone service...because I need the availability.

And they keep trying to sell Digital Phone....they do claim that I can keep my Broadvoice number, which would be a requirement. And, the current bundling savings me a ton of money....at least for the promo period. Hmmm, though its only the Essential bundle of digital phone...which is less services than I get now, including services I want...and normally for much more than what I pay Broadvoice. Though with bundling, it would only only cause my current service plan to go up by a couple of dollars. And, long distance would cost me more....

Wonder when U-Verse is going to get here. Annoying that some units in some buildings can get U-Verse, other units in some buildings have U-Verse. But, it says my unit in my building doesn't exist....yet I have DSL and they send me bills for it, so I surely exist somewhere....

Not sure if I'd go Internet only, or Internet + Phone. Phone seems to be missing one feature.... simul-ring.

1 ... 11 12 13 14 16 18 19 20 21 ... 141

Now instead of subjecting some poor random forum to a long rambling thought, I will try to consolidate those things into this blog where they can be more easily ignored profess to be collected thoughts from my mind.

Latest Poopli Updaters -- http://lkc.me/poop

bloglovin

There are 20 years 1 month 7 days 13 hours 56 minutes and 36 seconds until the end of time.
And, it has been 4 years 11 months 21 days 6 minutes and 20 seconds since The Doctor saved us all from the end of the World!

Search

December 2017
Mon Tue Wed Thu Fri Sat Sun
 << <   > >>
        1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 31
Google

Linkblog

  XML Feeds

Who's Online?

  • Guest Users: 0
This seal is issued to lawrencechen.net by StopTheHacker Inc.
b2evolution CCMS

hosted by
Green Web Hosting! This site hosted by DreamHost.

monitored by
Monitored by eXternalTest
SiteUptime Web Site Monitoring Service
website uptime