Tags: gigabit nic

03/27/11

  06:33:39 pm, by The Dreamer   , 817 words  
Categories: Hardware, Computer, Momitsu V880N, Networking, BOINC, Storage

worked on lhaven, kind of

It might be time I upgraded/replaced 'lhaven'.

This is the only computer in my home network that is only 10/100BaseT, everything else being gigabit. I did picked up a gigabit NIC, but couldn't get it to work in this computer. Seems to not get along with something integrated hardware-wise.

The other thing is there have been lots of errors coming from ata1.00 for sometime. This is also the remaining computer that uses PATA drives. 'lhaven' has 3 300GB PATA drives in it. The primary master (ST3300622A) and secondary master (6B300R0) were in RAID1 configuration, and the primary slave (WD3000JB) is just a single disk. secondary slave is the CD drive...forget what it is exactly.

It wasn't dire that I replace the failing primary master, though it had failed out once before....system booted off the secondary master and ran degraded. But, I added the disk back in and it quickly got happy again (have internal bitmaps enabled).

I had looked around and there isn't much in PATA drives available these days...and nothing in 300GB. Choices I found were 80, 320 or 500. I suppose I could've gone with a 320...but what I did instead of score a 300GB off of eBay.

Replacing it didn't go though. Failed out the disk, booted up on secondary, and tried to put in new disk. First cloning partition table over to new disk. Wouldn't work...new disk is smaller than the secondary master.

As it turned, out the two primary drives were the same size, but the secondary was slightly bigger. I had partitioned the drive using all the space, though it was never using all of it. Probably should've partitioned it the same size as the primary drives. But, I didn't recall this at midnight...figuring it was would go quick and let it resync while I slept....

So found details on shrinking things so that I could add the new disk. Then things got weird.

grub got messed up, and the new disk wouldn't come back correctly into raid. There seemed to be CHS issues, maybe the BIOS in 'lhaven' is too old for such a new drive (ST3300820A)...had seen messages about it, but was more stumped by why it kept changing the md1 slice from sda2 to sda...leading to nasty things as it tried to rebuild itself.

Also noticed that it did different things if it booted from the primary versus the secondary. Apparently the md0/md1 didn't show up soon enough so it used the partition directly.... and the sda1/sda2 paritions were kind of messed up. In fact the /home filesystem on one got seriously hosed, so I reformatted it. But, when I rebooted later..../home was back and working.

During this process grub got messed up, so I had to download a livecd to reinstall grub. Eventually, it all seemed to mostly be working. Except that I could only boot from the secondary master, it would come up wrong from the primary. And, the errors I was seeing that prompted this were still happening.

So, likely not a drive problem...but something else wrong with 'lhaven'. So, I decided to put the old primary drive back and resync that and put everything mostly back the way it was before.

It wasn't without some challenge...like how to make it not see the secondary master and get confused by it. I tried removing power to it, but computer wouldn't power up. I tried removing just IDE cable from it, BIOS halted because just a secondary slave wasn't kosher. It started things degraded, but used sdc1 as root (instead of md0 which should be sda1, with sdc1 out...zero'd it superblock) it was also weird on vg00. md1 wouldn't activate, but vg00 was using it some how. And, when I did activate it...I couldn't get sdc2 to add to it.

But, eventually it all got back to the way things were before.

So, I guess its time to see about replacing 'lhaven'. Its old enough. Though not sure what, besides case and powersupply are original from the computer I purchased in August 2002.

Hard to say what I'll replace it with though...since not much out there fits into where it is (perhaps its time to get a new KVM), and I'm going to want a pretty souped up system to speed up BOINC work....even though that's pretty much all it does these days. Since, everything is being handled on 'box'/'orac' now. And, the secondary services that do run on 'lhaven' don't call for anything beefy (DNS, NTP)....though I do want to redo my Linux media server setup.

My Momitsu V880N is probably going to get replaced sometime later this year... only had mmc running on 'tardis' and 'lhaven'. mmc doesn't work on vista/Win7, and 'tardis' is off in the corner to die. Could probably get mmc working on some other linux box if I needed, but its probably time to come up with something DLNA.... and have my Roku take over.

Now instead of subjecting some poor random forum to a long rambling thought, I will try to consolidate those things into this blog where they can be more easily ignored profess to be collected thoughts from my mind.

Latest Poopli Updaters -- http://lkc.me/poop

bloglovin

There are 20 years 1 month 24 days 6 hours 57 minutes and 42 seconds until the end of time.
And, it has been 4 years 11 months 3 days 7 hours 5 minutes and 14 seconds since The Doctor saved us all from the end of the World!

Search

November 2017
Mon Tue Wed Thu Fri Sat Sun
 << <   > >>
    1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30      
Google

Linkblog

  XML Feeds

Who's Online?

  • Guest Users: 0
This seal is issued to lawrencechen.net by StopTheHacker Inc.
powered by b2evolution

hosted by
Green Web Hosting! This site hosted by DreamHost.

monitored by
Monitored by eXternalTest
SiteUptime Web Site Monitoring Service
website uptime