Tags: virtualbox

Pages: 1

03/17/13

  03:10:00 pm, by The Dreamer   , 1773 words  
Categories: General, Computer, Home, Windows, FreeBSD, VirtualBox, Quicken/TurboTax

Did my taxes for 2012

Like I do every year, I bought TurboTax Premier Federal + E-File + State 2012 as a PC Download from Amazon.com back on Jan 18th, in part due to sale email from TurboTax. But, probably should've waited, because its cheaper now. Not sure why PC download is so similar in price to buying PC/Mac package. And, wasn't sure if I would still be on a PC.

In fact, I haven't had a physical Windows machine for almost 10 months now. Last year I did my taxes in a Windows XP VirtualBox VM on orac, since I had evolved to running Quicken in different XP VirtualBox VMs and using Dropbox to house my Quicken datafile. My first XP VM was on my laptop....and I spent part of Gallifrey One 2011 getting Quicken up and running in that VM and recovering my Quicken data. Where it seemed the best place to put the file was in my Dropbox. Have since adjusted things to make that work better to mostly cope with the locking issues between Quicken and Dropbox. I set up the one on orac which is where I did 'Windows' for about 9 months, and still use on occasion due to the lack of USB 2.0 support for VirtualBox on FreeBSD.

Though on zen, I have a Windows 7 VM (and still own another Windows 7 copy that I don't know where I'm going to put to use, just as I have a couple copies of XP still...been planning to put the 64-bit XP one into a VM on zen...but it hasn't happened yet.) Perhaps when I finally do get my Mac, I'll use some copies there.

Anyways...I would fire up TurboTax now and then, to see it get updates. Always thought it strange that after it said it was done that it would say that it was restarting TurboTax, but not. So, I never did more than see what updates it was getting.

But, I had intended to start my taxes last weekend...where DST began, though that turned out to be a bit of a weird weekend so I didn't get to it. I had actually intended the weekend before DST, but that also didn't pan out. But, seems tradition has been 2nd or 3rd weekend of March lately.... It is also for some reason the weekend that they always bring down HRIS for upgrades. As it happened this year, I did want to go on there and check something....

So, Friday night at 10pm I fired up TurboTax to see what updates, there were a lot. Been kind of unsettling lately...especially after the IRS Notice I got last year, which I dealt with using the services of Tax Resources...but it might have been a variation of a TurboTax bugs -- "Federal 2010: Customers with certain 1099-R retirement distribution codes" or "Federal 2010: Qualified Pension Conversion and Rollover" -- so I probably should've gotten TurboTax to take the heat for it.

Of course, TurboTax has had other issues in the past, and yet I stay with it year after year....

Full story »

03/07/13

  01:00:00 pm, by The Dreamer   , 370 words  
Categories: Computer, BOINC, Ubuntu, FreeBSD, Virtualization, VirtualBox

VirtualBox VDI and 4K alignment

So, after my Windows 7 machine at work ate itself after a Windows Update. I decided to turn it into an Ubuntu 12.04 system.

But, so much for becoming Windows free. I was informed that I need a Windows machine to run vCenter on, because the shared Windows 2003 server that we had been using is going away.

So, I setup Windows 7 in VirtualBox...pretty simple. But, soon I was getting ext4 messages complaining about unaligned access for a certain inode. The VDI for the Windows 7 install.

I searched around on VDI and 4K alignment, and eventually found this:

HOWTO: Modify empty VDI for optimal alignment of Windows

Though reading further it seems to suggest that newer versions of VirtualBox get the alignment right for you....and 4.1.24 is much newer than 3.0.12 in the original post. (had opted for 4.1.24, since 4.2.6 is not recommended for BOINC Test4Theory....but 4.2.8 is out now, and it is recommended....so it'll be time to go and update all my machines, I guess. The only systems with 4.2.6 were FreeBSD, because the 4.1.24 will cause the 9.1 kernel to panic on VM exit. though don't know if 4.1.24 was bad in ports or not, had been 4.1.22 before upgrading to 9.1 -- but had to recompile the kernel modules after the upgrade so had first tried 4.1.24....)

So, I went through the HOW-TO to create an new emtpy VDI...and found that it is already 4K aligned. So, why was the VDI created through the 'New Wizard' in VirtualBox Manager not?

Anyways...I then booted gparted and copied my partitions over to the new VDI....and then had to boot the Win7 installer to fix the startup to get it to boot, and no more complaining.

:hmm:

Guess I'll have to remember to create VDI before creating the new VM in the future? Wonder if there are issues in other disk image formats. Wonder if ZFS would complain that my VDI isn't aligned? Wonder how to check? Though the other formats I use are either VHD or VMDK. VHD because that's what Microsoft Windows Image Backup creates, and I'm using the last one of Zen to try to recover files from.... VMDK is after an import/export of a VM or for raw zvol accesses. So, guess those aren't areas of concern for me right now.

02/07/13

  10:09:00 am, by The Dreamer   , 1100 words  
Categories: Software, Computer, BOINC, Storage, FreeBSD, VirtualBox

I upgraded to Zen to FreeBSD 9.1

I have a number of FreeBSD projects at home on the go that I've been trying to find enough free time each weekend to tackle. Having a recent problem where my system will freeze/panic/reboot whenever I shutdown or saved a VM...I thought maybe upgrading to 9.1 would help. It didn't.

Anyways...I wondered how freebsd-update would proceed, given that checksums on everything had changed...because at one point during things I had rebuilt the world with optimized compile flags, though otherwise still running GENERIC and no other alterations, though later rebuilding kernels so uname would reflect p4 and p5....

But, from what it said it was going to do to get me upgraded, it seemed okay with everything. Though the merge was a bit strange....first time through it didn't present one of the merge conflicts for me to resolve (/etc/login.conf), so I said no when it asked if the file was ok before proceeding. That just stopped it instantly, had hoped that since it didn't ask how to resolve before that it would ask now. But, running the update again....it did ask for that file this time (otherwise I was considering what would happen if I fixed it by hand during or later.... So, then it went and upgraded.

And, then that's where all the fun started. While rebuilding all my ports wasn't necessary. It was necessary to rebuild all the ports that create kernel modules....like nvidia, virtualbox, fuse, webcam....

Full story »

01/24/13

  10:23:00 pm, by The Dreamer   , 1549 words  
Categories: Hardware, Computer, Storage, Ubuntu, FreeBSD

SSD Craziness

Over the last year, I started buying SSD drives. It used to be that they seemed pretty expensive, and of questionable performance and reliability. But, all things have improved over the years. And, when 120GB drives dropped under $1/GB (initially after rebates, later before rebate [if any]). I didn't have an immediate need for an SSD drive at the time, but I envisioned replacing the drive in my (u) laptop. And, perhaps my (w) laptop....beyond that I wasn't sure.

 3/05/12 - Patriot Pyro 120GB             - $159.99-$40 rebate = 119.99
 3/20/12 - OCZ Agility 3 120GB            - $139.99-$30 rebate = 109.99
 4/27/12 - Mushkin Enhanced Chronos 120GB - $ 99.99
 5/16/12 - OCZ Solid 3 60GB               - $ 74.99-$20 rebate =  54.99
 8/10/12 - Sandisk 128GB                  - $ 79.99
11/21/12 - Kingston HyperX 2K 240GB       - $149.99
 1/18/13 - Sandisk Extreme 120GB          - $ 89.99-$15 reward =  74.99
 1/18/13 - Sandisk Extreme 120GB          - $ 89.99-$15 reward =  74.99

But, during this time...I had the lhaven misstep Where I had picked up the 60GB drive for that, but ended up using the Mushkin 120GB drive instead. The OCZ Agility 3 120GB had gone in as OS drive for my Xen Cloud Experiment. And, stayed when I went on to making it FreeBSD. Cut up initially as 64k boot, 32GB swap, 16GB L2ARC for the mirrored 1.5TB drives to help with dedup...and the rest...63GB root zpool.

Somehow the Patriot got misplaced for a while, so it got overlooked during the chaos.

After a 'break'. I picked up the Sandisk 128GB drive. Thinking that it might be a better choice to use to finally replace the (u) laptop harddrive. Though I waited until after the NN conference in October to do it, but before I went to LISA in December. Though I didn't finally upgrade the the OS to 12.04 (from 10.04) until just last week. I had thought about doing a clean install to 64-bit....since there were some issues since I upgraded the memory to 8GB. But, changing the hibernate method seemed to have solved the issue....so decided to leave it 32-bit. Though my (w) laptop is 64-bit...though it only has 4GB. Not sure if I'll upgrade it to 8GB. Or when I'll upgrade its harddrive to SSD.

Things have been kind of tight since...on the 128GB Sandisk drive. partly because swap got a bit bigger...had suspected that 8GB swap was iffy for hibernation....so had bumped that up. Plus the original harddrive was 160GB. But, the lion share of space consumption is my Windows XP VM. But, it get's the job done.

Meanwhile...around this time I got the idea that instead of making the risky upgrade of my two Ubuntu servers from 10.04 to 12.04, that I would set up two new FreeBSD servers and migrate the essential services over before deciding the future of those systems. So, I acquired a pair of Shuttle XS36V's...4GB of memory for each...and then eventually the plan was to acquire a pair of SSDs for them. Which I finally did last week as a pair of SanDisk Extreme 120GB drives. (with the help of $30 from Best Buy Reward Zone....and this purchase should get me a $5 reward zone soon.) And, these will probably get installed as FreeBSD 9.1.

Pages: 1· 2

12/22/12

  09:58:00 pm, by The Dreamer   , 1422 words  
Categories: Hardware, Software, Computer, Storage, Operating Systems, Ubuntu, FreeBSD, Virtualization, Other Linux

zen resurrection

This was originally going to be a very long post, but I kept putting this off ... and now I just feel that something needs to be said.

The story starts with waking up on February 15th, to find zen was dead. It had self updated overnight, and now it was unbootable, and the start repair couldn't get me back. Apparently, the problem had started long ago with all the previous times where Windows 7 would lock up...usually under intense disk activity...and the afterwards, the intel matrix raid would require re-initialization of my 1.5TB RAID 1 array.

Apparently, it was slowly corrupting my drive....because trying to restore from WindowsImageBackup was also a failure. Since this happened the day before Gallifrey One, I had to wait until I got back to do some more serious attempts to recovery, during which I ordered a full copy of Windows 7 Professional, hoping that a repair install might be an option. It isn't because the repair option can only be invoked inside a running Windows 7 system .... in need of repair. Not by booting the disk. ARGH! :##

At least I should have the data in BackupPC to restore from.....though hopefully before the bit rot of its ext4 filesystem makes it go away. Plus I had hoped to get some configuration going where I could mount the RR62x RAID 5 array, and get at the Oops!Backup store.

So, the plan now was to wait until Ubuntu 12.04LTS to land and then maybe some configuration of running Windows 7 in VirtualBox and recovering into that, etc.

Pages: 1· 2· 3

03/17/12

  06:53:00 pm, by The Dreamer   , 337 words  
Categories: Hardware, Software, Computer, Healthcare, Windows, VirtualBox, Quicken/TurboTax

CPAP Data Recovered

As I may or may not have mentioned, Zen failed to boot after it got the latest set of Microsoft patches on February 15th. After various attempts to recover, it has been declared lost. I haven't gotten around to resurrecting it.

So, I've been making do with a Windows XP VirtualBox that I have my on Linux system (starting to look like when I do get around to resurrecting it, I'm going to try 12.04LTS Desktop and Windows 7 in VirtualBox....)

Previously, it was just Quicken and then TurboTax. But, I've been wondering about my CPAP data.

First was EncoreViewer. How do I recover that historical data. I knew where it kept the files, because I had copied them from TARDIS into Windows XP mode. The question now was how do I get the files out of Windows XP mode. In the end, the answer was WinImage...to merge the differencing-VHD that Windows XP Mode uses, into a single file and then convert it for VirtualBox use. Could've gone direct...except that I found first try with WinImage didn't work...so second time I converted to a fixed VMDK file, and then converted the fixed file into a dynamic sizing virtual disk for use on VirtualBox.

Though later I realized that I only want it as read-only....to get my data back....anyways.

That worked.

Next question was how do I recover my data in SmartLink.

I installed it into my Windows XP VirtualBox, and wondered where does C:\ProgramData exist in Windows XP space....but, while poking around, I remembered it has a backup/restore database option...and wondered if I had ever done a backup.

I lucked out. The last time I used the software was the only time I had ever used the backup function....and that's just perfect, I restored from that and then did my latest downloads from both my xPAPs.

:cool:

Just have to see if I remember to do another download before my next doctor appointment. I didn't print anything, because I hope that by then...I'll also have my new printer. :))

03/10/12

  07:23:00 pm, by The Dreamer   , 287 words  
Categories: General, Quicken/TurboTax

Doing my Taxes for 2011

So, again this year, I bought TurboTax Premier 2011 as a download from Amazon.com. But, then on February 15th, my Windows 7 computer crashed. Or rather it auto updated and wouldn't boot. After a couple weeks of various attempts to fix it, I've written it off. Hopefully, my backups were good...and I'll eventually get around to rebuilding that.

In the meantime, I fired up my XP VM...installed Quicken Premier 2012 and recovered a backup of my Quicken data..and had been continuing to use that. So with likelihood of getting Windows 7 running in my home again anytime soon, being low. I reinstalled the recently purchased TurboTax Premier 2011 into the VM debated when I would make a start.

After the initial update, it noted that on or before March 8th, there would be another update. So I decided I would defer to then. I had intended to pop on to HRIS sometime before then to check something, but I didn't remember that I needed to do it until after I took the system down for planned weekend upgrades. As it was, there wasn't anything I needed from it anyways.

Pages: 1· 2

12/30/10

  10:06:48 am, by The Dreamer   , 891 words  
Categories: Digital Photography, Hardware, Software, Computer, Networking, TV, Storage, Healthcare

December 30th Migration Update

Again, last night I didn't do as much work on migration as I hoped, between feeling some what really sleepy...which passed after a little sit on sofa where I had to go back to the beginning of the show I was watch to find out where I really was at....and watching the two part Christmas themed episodes of "The Closer".

The goal I had set out was to finally install my ScanSnap S300 and maybe EncoreViewer (which I had heard wouldn't work, but I had to see for myself). I also did some other things like install and move Eye-Fi, checked that I could manage the cards using the built-in SD card slot (doesn't work on my laptop, but it worked here). EncoreViewer wouldn't work...people had said it wouldn't work on 64-bit Windows 7, though reports are that the 2.0 version will...but don't need it yet, so don't feel like buying it. I'll probably see about getting XP Mode and see if that makes it work, otherwise there's VirtualBox...which I know works. I think I have one unopened copy of XP left.

I did some poking around on TARDIS last night, first it was move the LabelWriter 320 to there for eventual reconnection. Later it was to put the SmartCard reader for EncoreViewer back on the computer. I decided to plug the LabelWriter back in and see if I could share it. It wasn't working...apparently it doesn't like being connected to the USB hub. It used to be on a USB hub...though that's probably why it was the only thing that was still plugged into the old USB 1.1 hub. I didn't keep it when I moved TARDIS...

Seems the 6 USB ports on the back of the computer is a really limited quantity, with all the things that won't run on hubs. :## A bigger problem on the new computer, because the keyboard and mouse each take up one of the precious ports. I'm using one for the direct connection of my UPS, another will be for the external drive for local backup, one is the USB hub....that leaves one left, and that'll probable be the webcam.

The 7-port USB hub is filling up too, though not as fast since the LabelWriter320 isn't supported on Windows 7. So far its LabelWriter 400, SnapScan S300 and the USB to serial adapter (I mentioned yesterday). Maybe I'll replace the hub with one with more ports....chaining this hub so to the otherside of my desk...

During the LabelWriter 320 on TARDIS process, I had to reboot. So, I decided to disable a bunch of things that start up when it boots that didn't need to be there anymore. Mainly the stuff for ScanSnap and the many IM clients. And, with the IM clients stopped, I started working on installing and configuring some of the IM clients on Zen. I should get to getting the webcam working soon.

Installed some other stuff like Tweetdeck, Picasa...then decided that I should work on the backup drive.

I populated my old Sans Digital TR2UT-B with a pair of Seagate 1.5TB drives, one that I had on hand plus the one I received today via Amazon Prime. Had to remember how to get it to make a mirror, and then it went about its business. Wonder where the CD for it went to, and whether the monitoring software would work on Windows 7.

Now, I had commented how quiet the living room had become when I moved TARDIS out. It stayed quiet with Zen setup. This HP is much quieter...even when it has BOINC hammering it. But, the quiet has ended, because the fan in the Sans Digital TR2UT is quite noisy. At first I was going to put it near the computer on it or on my desk, but I switched to putting it down lower as far as the cable would let me. on nearby bookcase....same shelf where I used to have external drives for much the same purpose in the past...

After I had gotten the drive formatted, it detected the addition and asked what I wanted to use it for. So, went into using it for backup. It already takes a while to do a backup...also less free space on it than system drive....wonder if I shouldn't have gone with the 2TB external instead now.

Then I thought I should see about getting backuppc going, but left the things for the night to let the backup complete (and the raid1 build to finish).

Pages: 1· 2

10/31/09

  01:36:00 pm, by The Dreamer   , 568 words  
Categories: Software, Computer, BOINC, Ubuntu

upgrading to Karmic Koala

I hadn't intended to start upgrading systems to Karmic Koala so soon...since the servers are kind of pegged with other people downloading and upgrading. But, playing around with do-release-upgrade on my Ubuntu server at work....at first (on Thursday) it didn't show the release and the later it did.

Since its running as a Guest on my Solaris 10 x86 desktop, in VirtualBox, I could take a snapshot and let it go. Plus its a pretty minimal server...its just to run BOINC. It estimated that it would take about 4 hours to download what it needed. Guess it doesn't take advantage of the I2, or things were pretty saturated....

When I came in yesterday, it was still going...was kind of hard with it blanking the screen and stopping waiting for input...but it kept chugging along and eventually upgraded and all seemed good.

So, last night I decided to pull the trigger and upgrade my notebook (ulkc). It warned about a lot more stuff that was unsupported and would be removed, and lots of warnings about all the 3rdparty stuff. But it gave an estimate of 10 hours to download and asked if I wanted to continue.

Sure :lalala:

When I got up the next morning it was waiting to ask about differences in my mod blacklist, it wanted to add pcspkr but it wasn't going to keep the modules I had blacklisted...and no option to merge or stuff....so I told it to keep my blacklist. Wonder what'll happen when I do box, since there's nothing connected to its sound card....so its only way to make noise is through its pc speaker.

After it was done and rebooted, two things didn't work. The firefox button on the panel, since default had changed from firefox 3.0 to firefox 3.5 (though I've been using 3.5 since it came out, just replace /usr/bin/firefox with a new symlink)....easy enough to replace. And, virtualbox.

I reinstated the 3rdparty sources for apt, and checked for updates. Guess there's no Karmic repository for Boxee yet. The only thing that did upgrade was dropbox.

So, I uninstalled virtualbox (it was 2.2) and reinstalled it (3.0 from the karmic repo). And, then I tested it.

It worked.

Full story »

10/28/09

  01:44:03 pm, by The Dreamer   , 283 words  
Categories: Stuff, Home Theatre, Hardware, Software, Computer, Networking, TiVo HD / Premiere / Elite

Yet another PowerSource 400

Wonder if the people at Xantrex or Amazon.com are wondering what's with all the PowerSource 400s I've been buying?

The latest acquisition brings the total to 5. With the latest being the 3rd unit in one room.

Somewhere in a past shuffle/outage...I had lost a UPS (CPS700AVR), and lost a computer (box). I had rebuilt box, and as interim....put it on the PowerSource 400 that was backing up 'lhaven'. I also put the 8-port [end] switch and my wireless access point onto this PowerSource 400.

This cuts into the available runtime, and its important to me that 'lhaven' never go down. Though its also important from the operation of my home network that 'box' never goes down. And, of course, the switch...and maybe the wireless access point. Though other parts of my home network are on different PowerSource 400's. The stack of equipment at the DSL point is on one, and the stack of equipment at the Cablemodem point on another (though it also includes extra things like 2 TiVo HD's and Expanders and other HT equipment)

So, I have moved 'box' and the network equipment here to the new PowerSource 400....leaving 'lhaven' on its own.

Now the question is whether or not there'll be another 1 in the future....for 'orac'.

Pages: 1· 2

1

Now instead of subjecting some poor random forum to a long rambling thought, I will try to consolidate those things into this blog where they can be more easily ignored profess to be collected thoughts from my mind.

Latest Poopli Updaters -- http://lkc.me/poop

bloglovin

There are 20 years 1 month 3 days 20 hours 55 minutes and 1 second until the end of time.
And, it has been 4 years 11 months 24 days 17 hours 7 minutes and 55 seconds since The Doctor saved us all from the end of the World!

Search

December 2017
Mon Tue Wed Thu Fri Sat Sun
 << <   > >>
        1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 31
Google

Linkblog

  XML Feeds

Who's Online?

  • Guest Users: 0
This seal is issued to lawrencechen.net by StopTheHacker Inc.
Advanced CMS

hosted by
Green Web Hosting! This site hosted by DreamHost.

monitored by
Monitored by eXternalTest
SiteUptime Web Site Monitoring Service
website uptime